Sorry but this application doesn't support your device at the moment

Hi,

I have a pixel 6a with Android 13. Does nulls clash not support it?

yes it doesn’t🗿

It’s an android, so yes

no, not all android versions are supported.

Most likely you’ve installed A13 Developer Preview version that doesn’t support now. Google Pixel moment